SimPE - Links, Tutorials und Fragen

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Die Meldung kommt -glaube ich- wenn man ein Programm nutzt, dass mit SimPE nicht so richtig "kompatibel" ist. Diese Meldung bekommt man beispielsweise auch bei C4D. Eventuell brauchst du noch ein Plugin für 3dsmax? Am Objekt dürfte es -glaube ich, bis Juls was anderes sagt=)- nicht liegen.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Ich verstehe Dein Problem nicht so ganz - wo und wann bekommst Du diese Meldung? Etwas mehr Info wäre hilfreich. ;)
Und was ist mit dem Bild? Was meinst Du genau, was ist daran nicht in Ordnung?
Btw.: das Bild ist auch zu groß, das müsstest Du bitte verkleinern - es sind maximal 800 x 600 Pixel erlaubt.
 

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Du kannst es auch mal mit Wings oder Anim8or versuchen. Diese beiden Programme sind zumindest kostenlos. Versuch erst einmal das, bevor du dich in "Unkosten" stürzt.

@Juls: Diese Meldung bekommt man manchmal beim Importieren in SimPE. Passiert halt, wenn man keines der oben genannten Programme oder eben Milkshape (oder was sonst noch geht) verwendet.
 

Plermpel

Member
Registriert
November 2010
Alter
51
Ort
Gigarizpotschn
Geschlecht
m

Ich habe mir jetzt Wings 3D geladen und das Objekt dort importiert, im Programm sieht es auch richtig aus. Anschließend hab ich es wieder als .obj exportiert und als ich es in SimPE importiert habe kam wieder der Fehler???
 

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Du kannst mir gerne mal das reine 3DModell schicken und ich schau drüber. Im Moment könnte es an allem Möglichen liegen beispielsweise an den Normalen.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Naja, Milkshape kostet um die 25 Euro, falls sich da nix gravierendes geändert hat. Als "Unkosten" würde ich das nicht bezeichnen, wenn man es mit 7100 Euronen für 3DS vergleicht.
Für Milkshape spricht einiges, wegen der Plugins, die es speziell für Sims dafür gibt. Einige bestimmte Dinge kann man ausschließlich mit Milkshape machen, soweit ich weiss.
 

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Deshalb ja auch in Anführungszeichen:lol:.
Ich muss die Problemstellung mal an dich weiterleiten. Ich fidne den Fehler nicht.
Meine bisherigen Erkenntnisse:
Trianguliert sind die Sachen. Es ändert sich auch nichts, wenn ich bei diese Option anwende. Daran scheint es also nicht zu liegen.
Einige Faces sind verkehrt herum. Die Normalen müssen also umgedreht werden. Aber auch das hilft nicht wirklich weiter.
Ich habe beim Abspeichern in C4D schon die erste Fehlermeldung und ein Objekt wird in zwei Teile zerlegt. So was hatte ich noch nie. Das Programm meckert irgendetwas wegen BakeUVs failed.
Trotzdem habe ich mal versucht, den Drehstuhl in SimPE zu importieren. Ich bekomme dann auch diese Index-out-of-range-Meldung.

Ich kapituliere.

Plermpel, hast du noch irgendetwas am Modell verändert gehabt? Denn eine package-Datei hast du ja schon mal erstellen können. Mit Objekt drinne. Und nun geht nichts mehr?
 
Zuletzt bearbeitet:

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

So, ich hab die .objs mal gecheckt.

Entweder SimPe in den "Advanced Modus" bringen (Extra > Preferences > SimPe Settings > Advanced Mode)
Ich hab den Advanced Mode immer an, der Fehler tritt bei Plermpels objs trotzdem auf.

oder schauen, ob zu viele Gruppen vorhanden sind (du darfst den Mesh nur als eine Gruppe aus dem Mapping Programm exportieren, wenn der Klon nur eine Gruppe hat).
Das... stimmt aber nun überhaupt nicht. ;)

Ich hab die .objs in Milkshape importiert und unverändert gleich wieder exportiert - kein Fehler mehr beim Einlesen in SimPE. Ich würde also Milkshape zum Umsetzen empfehlen.
Ich würde aber zusätzlich noch dazu raten, trotzdem auch noch die leere Meshgroup namens "default" zu löschen.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Ist ja spannend.
Ich vermute, dass das hat dann vielleicht eher was damit zu tun hat, wie die .obj aus Deinem Mapping-Programm heraus angelegt wird - also vermutlich hängt es mit dem Format der .obj zusammen. Die Import-Funktion für .objs in SimPE ist ja erst später dazu gekommen (ganz am Anfang musste man noch einen Umweg über ein Extra-Tool nehmen, um die Meshes ins simpe-Format zu kriegen und die komplette GMDC wurde ersetzt), ich könnte mir denken, dass der .obj-Importer in SimPE auf dem Milkshape-Format basiert. .obj ist wahrscheinlich nicht immer exakt .obj, könnte schon sein, dass es da geringfügige Abweichungen gibt, je nachdem, aus welchem Programm exportiert wurde. Bei FBX z.B. ist das ja leider oft so. :(
Nachdem ich die .objs von Plermpel einmal durch Milkshape gejagt habe, konnte ich die Meshes ja auch problemlos in SimPE importieren.
Eventuell könntest Du ja auch mal probieren, ob der Fehler verschwindet, wenn Du die .obj nach dem mappen einfach nochmal in Milkshape importierst und wieder exportierst.
Ich meshe und mappe für Sims 2 ja im Großen und Ganzen ausschließlich in Milkshape und hatte diesen Fehler noch nie, und ich haue auch oft Meshes mit fünf bis acht Meshgroups in Klone mit nur einer Meshgroup, dem Importer ist das schnurz.
Hängt wahrscheinlich wirklich mit dem Format der .obj zusammen, die aus dem Mapping-Programm kommt. Ich mappe ja in Milkshape und benutze extra Mapping-Tools nur in bestimmten Einzelfällen und auch da nie für die Endversion, sondern arbeite meist in Milkshape nochmal nach. Daher kommen meine .objs halt immer aus Milkshape, und ich hatte, wie schon gesagt, diese Fehlermeldung noch nie beim Importieren.

EDIT: Hätte ich ja auch schon eher drauf kommen können - nachlesen hilft. :lol: Es liegt tatsächlich am unterschiedlichen .obj-Format der einzelnen Programme: http://sims.ambertation.de/en/kb/entry/2/

 

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Na das hätte ich dir auch sagen können. Wenn ich so spät noch wach gewesen wäre:lol:. Für C4D gibt es ein obj-plugin. Aber das ist SimPE Wurscht. Da heißt es dann, noch einmal mit Wings oder Anim8or importieren und neu abspeichern. Und bei Objekten mit mehreren Meshgroups muss jede Gruppe in einer Einzeldatei gespeichert sein.
Kurios finde ich hier nur, dass sich Plermpels Objekte wohl anfangs importieren ließen. Die package-Dateien existieren ja schon. Sehr merkwürdig.
 

Plermpel

Member
Registriert
November 2010
Alter
51
Ort
Gigarizpotschn
Geschlecht
m

Ich hab die .objs in Milkshape importiert und unverändert gleich wieder exportiert - kein Fehler mehr beim Einlesen in SimPE. Ich würde also Milkshape zum Umsetzen empfehlen.

Dann dürfte Wings 3D doch nicht sooo kompatibl mit SimPE sein ich habe damit nähmlich genau dasselbe gemacht und hat nix geholfen.

Hängt wahrscheinlich wirklich mit dem Format der .obj zusammen, die aus dem Mapping-Programm kommt.

Ich habe beim .obj exportieren in 3DS Max einige Einstellungen, ich werde da mal ein bisschen rumspielen.

ps.: Habe mir jetzt Milkshape (Trail) gezogen und sobald ich auf Export...>Wavefront OBJ klicke schließt sich das Programm einfach:confused:
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Hast Du Dir Milkshape von hier geholt? Wenn ja, welche Version? Die 1.85 ist ja noch Beta, eventuell probierst Du es mal mit der 1.84.
Ich benutze immer noch die 1.82, weil ab der 1.83 eine Änderung im UV-Mapping Tool war, die mir nicht gefällt.
Eventuell liegt es auch daran, dass die Exportfunktionen in der Testversion deaktiviert sind, da bin ich nicht sicher. Ich meine, dass das früher nicht so war, kann sich aber natürlich mittlerweile geändert haben. Ist ja häufig so, dass exportieren in Testversionen nicht geht.
 

Plermpel

Member
Registriert
November 2010
Alter
51
Ort
Gigarizpotschn
Geschlecht
m

Hast Du Dir Milkshape von hier geholt
Ja von hier geholt.
Wenn ja, welche Version?
MilkShape 3D 1.8.5 Beta
Eventuell liegt es auch daran, dass die Exportfunktionen in der Testversion deaktiviert sind
Manche Export-/Importfunktionen sind deaktiviert, manche nicht.

Ich habe es schon geschaft, man muss einfach nur schnell sein:D, aber ich werde es trotz dem mit der 1.82 probieren
Danke

EDIT: Hab mir jetzt 1.82 gezogen, genau das gleiche, Crash nach etwa 15 Sekunden.
 
Zuletzt bearbeitet:

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Da Du ein Unix und ein Windows aufgeführt hast, dachte ich, Du hast eventuell eins der Systeme in einer virtuellen Maschine laufen. Damit laufen sozusagen beide BS "gleichzeitig" auf einem Rechner, eins davon in einer Art Extra-Fenster.
Ich hab z.B. auf meinem PC Win 7 als Hauptbetriebssystem und lasse ein Linux in einer virtuellen Maschine laufen, für die Programmierung meiner Homepage.

Ich wollte halt wissen, ob Du als Hauptbetriebssystem eventuell das Unix drauf hast und das Windows in einer VM läuft, aber diese Frage hat sich ja dann erübrigt. ;)

XP ist eigentlich auch völlig unproblematisch für Milkshape, leider kann ich da jetzt aus der Ferne auch nicht mehr weiterhelfen. :(
Vielleicht behebt sich das Problem nach der Registrierung von Milkshape von selber, vielleicht aber auch nicht. Eventuell könntest Du im Milkshape-Forum nachfragen, der Entwickler antwortet dort auch, wenn man Glück hat. ;)
 
G

Gast297

Tut mir Leid, wenn das eine doofe Frage ist, aber wie kann ich meine Baumodus-Objekte ins Spiel bringen, bzw. Sachen aus dem Baumodus recolourieren? Ich hab da bisher nichts gefunden .... :schäm:
 

Franzi1982

Member
Registriert
Januar 2009
Ort
wieder daheim in FF
Geschlecht
w

Wenn ich bei Fenstern mit Master und Slave arbeite, ervlinke ich da die diagonalen Fenster auf das entsprechende "gerade" Fenster oder auf das Masterfenster? Oder ist das letztendlich wurscht?
 

Aonda Needles

Member
Registriert
September 2009
Ort
Essen (NRW)
Geschlecht
w

Hallo!
Ich versuche gerade, eine Nachbarschaft (siehe nächste Klammer) als Unternachbarschaft in eine andere zu integrieren. Bin nach den Anweisungen der Erstellerin verfahren (hier), zumindest bis zu dem Punkt 4. (In SimPE, extract all Lot Descriptions (LTXT) from N515_Neighborhood.package) Wie extrahiere ich ein Grundstück genau? Hab jetzt schon selbst nach einer Antwort gesucht, konnte aber leider keine finden.
Danke schon im Vorraus,
Aonda
 

juliane*

Member
Registriert
April 2004
Ort
Sternental
Geschlecht
w

Ich möchte zu einigen Frisuren, die ich mir runtergeladen habe, Recolors erstellen. Kann ich mit SimPE die Download-Texturen durch meine eigenen ersetzen? Ich würde mir gerne das Color-Binning und das Umstylen der Sims, die die Frisuren schon tragen, ersparen. Die ursprünglichen Texturen möchte ich dann auch nicht mehr haben und ich mache es nur für mich, also sollte das doch gehen, oder?
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

@LiT: Der Link zu den DDS-Utilities ist im ersten Posting dieses Threads zu finden, unter "Tools & Plugins", samt Installationsanleitung.

@juliane: Du bekommst doch mit dem Bodyshop die Texturen als bmp, oder? (Ist schon ne Weile her, dass ich mal Haare gemacht hab). Wenn Du dann mit SimPE das Originalpackage der Haare öffnest, musst Du die Texturen (TXTR) durch Deine eigenen ersetzten.
 

juliane*

Member
Registriert
April 2004
Ort
Sternental
Geschlecht
w

@juliane: Du bekommst doch mit dem Bodyshop die Texturen als bmp, oder? (Ist schon ne Weile her, dass ich mal Haare gemacht hab). Wenn Du dann mit SimPE das Originalpackage der Haare öffnest, musst Du die Texturen (TXTR) durch Deine eigenen ersetzten.

Ja, Bodyshop gibt mir ganz viele bmp-Dateien, die beim Recolorieren auch bmp-Dateien bleiben ... Wie komme ich denn an die TXTR-Datei(en)? Muss ich mein Recolor erst im Bodyshop "ins Spiel einfügen" und dann mit SimPE öffnen? Oder kann ich die TXTR-Datei irgendwie aus den bmp-Dateien herstellen?

Ich hab doch fast keine Ahnung von Dateitypen :heul:.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Nein, nein. ;)
Es ist viel einfacher - Du öffnest einfach das Original-package, in dem Du die Texturen austauschen willst, mit SimPE. TXTR ist kein Dateityp, sondern ein Resourcetyp - so heissen die Textur-Resourcen im package.
Du klickst einfach links unter "alle Resourcen" auf "Texture Image (TXTR)", dann erscheinen im rechten oberen Fenster (Resource List) die einzelnen Textur-Resourcen.
Die klickst Du nacheinander an und ersetzt die darin enthaltenen Texturen durch Deine veränderten bmps, indem Du im unteren Fensterteil einen Rechtsklick direkt auf das Bild machst und "Build DXT" auswählst. Dann geht der DDS Builder auf, und in dem klickst Du auf das blaue "open". Dann geht ein Explorer-Fenster auf, in dem Du zu Deinen bmps wechseln und das richtige auswählen kannst. Wenn Du dann wieder im DDS Builder ist, klickst Du unten rechts auf "Build", und damit wird Deine Textur in die TXTR eingelesen.
Bei Haaren und dem bmp-Dateiformat musst Du dann vermutlich, je nach Frisur, nochmal einen Rechtsklick auf das Bild machen und "Import Alpha Chanel" ausführen und die schwarz/weisse Alpha-Textur importieren.
Zum Abschluss nochmal einen Rechtsklick auf das Bild machen und "Update all sizes" anklicken, dann auf "Commit" an der oberen rechten Kante des unteren Fensters.
So arbeitest Du alle Texturresourcen ab, und am Ende das package noch speichern.
 

juliane*

Member
Registriert
April 2004
Ort
Sternental
Geschlecht
w

Ach sooo! Danke!!

Gerade hat sich ein Riesenknoten in meinem Gehirn gelöst! Dankedankedanke!!

(Ja, ich weiß, dafür gibt es den Button, aber der ist mir grad nicht überschwänglich genug ;).)
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Die Thumbnails sind nicht in SimPE enthalten, die werden vom Spiel generiert. In SimPE ist nur die Kameraposition gespeichert, die für die "Aufnahme" des Thumbnail-Bildes benutzt wird.
Es gibt verschiedene, unterschiedlich komplizierte Möglichkeiten, die Position und Größe des Thumbnails zu verändern.
Ich fange deshalb mal mit der einfachsten an:
geh in die CRES und wähle in der Blocklist den Eintrag "thumbnailExtension" aus. Wenn es dort in dem mittleren Fenster einen Eintrag gibt, klicke ihn an und lösche ihn mit dem kleinen blauen "delete" unten rechts, dann "Übernehmen" und package speichern.
Das sollte dafür sorgen, dass ein neuer Thumbnail erzeugt wird, der der Größe des Objekts entspricht.
Probier das mal aus, vielleicht erzielst Du damit schon den gewünschten Erfolg. Falls nicht, melde Dich einfach nochmal, dann versuchen wir es komplizierter. ;)
LG!
 

juliane*

Member
Registriert
April 2004
Ort
Sternental
Geschlecht
w

julsfels, deine Anleitung ist super :). Jetzt frage ich mich aber: Muss ich überhaupt den Umweg über den Bodyshop machen? Oder kann ich auch das package in SimPE öffnen, die Texturen als png exportieren, ändern und dann mit Build DXT wieder reinbringen?
 

juliane*

Member
Registriert
April 2004
Ort
Sternental
Geschlecht
w

Da sind aber transparente Teile dabei. Dann geht das nicht, oder?
Also doch lieber bodyshoppen?

Edit: Huch, geht das doch?


Ok =).
 
Zuletzt bearbeitet:

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Das ist egal, wenn da transparente Teile dabei sind - das wird später über den Alpha-Chanel wieder reingeholt. Du musst nur mit einem Rechtsklick auf das Bild auch "Export Alpha Chanel" ausführen, dann hast Du auch die schwarz/weiße Alpha.
Wenn Du dann die bmp bearbeitet und importiert hast, holst Du die Alpha mit "Import Alpha Chanel" wieder rein, und dann wird auch die bmp direkt im package wieder transparent.
 
  • Danke
Reaktionen: juliane*

Ravenfeather

Member
Registriert
Mai 2010
Ort
Baden-Württemberg
Geschlecht
w

Die Thumbnails sind nicht in SimPE enthalten, die werden vom Spiel generiert. In SimPE ist nur die Kameraposition gespeichert, die für die "Aufnahme" des Thumbnail-Bildes benutzt wird.
Es gibt verschiedene, unterschiedlich komplizierte Möglichkeiten, die Position und Größe des Thumbnails zu verändern.
Ich fange deshalb mal mit der einfachsten an:
geh in die CRES und wähle in der Blocklist den Eintrag "thumbnailExtension" aus. Wenn es dort in dem mittleren Fenster einen Eintrag gibt, klicke ihn an und lösche ihn mit dem kleinen blauen "delete" unten rechts, dann "Übernehmen" und package speichern.
Das sollte dafür sorgen, dass ein neuer Thumbnail erzeugt wird, der der Größe des Objekts entspricht.
Julsfels, du kannst wirklich immer helfen! *staun*
Danke, ich werde es ausprobieren.
Edit: Hoppla, jetzt stimmt die Reihenfolge unserer Posts nicht mehr, hab hier etwas rumgemurkst (Löschen - Neuposten). :ohoh:
 
Zuletzt bearbeitet:

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Nicht immer. ;)
Wie gesagt, wenn das nicht den erwünschten Erfolg hat, melde Dich nochmal.

Edit: Hoppla, jetzt stimmt die Reihenfolge unserer Posts nicht mehr, hab hier etwas rumgemurkst (Löschen - Neuposten). :ohoh:
Ätsch, kann ich auch. :lol:
 

Amy.Chagall

Member
Registriert
Januar 2012
Ort
Schönschüchtingen
Geschlecht
w

Julsfels... weißt du vielleicht warum mein Cinema die Meshes auf den Kopf gestellt in SimPe exportiert? Vorher hatte ich das Problem nicht, und im Cinema sehen sie normal aus... :confused:
 

Zur Zeit aktive Besucher

Oben Unten