• Aus gegebenem Anlass...

    ...weisen wir nochmals darauf hin, dass hier im neuen Forum nur noch jpg als Bildformat zugelassen ist.

    Dies gilt auch für externe Hoster oder Bilder auf dem eigenen Webspace!


    Bitte achtet darauf, dass ihr am besten eure pngs bereits vor dem Hochladen auf eine externe Plattform in jpg umwandelt, da manche Hoster die Bilder nicht wirklich konvertieren, sondern nur die pngs als jpg verlinken.
    Alternativ könnt ihr die Bilder auch als png direkt in den Beitrag reinziehen (oder als Anhang hochladen und dann in den Beitrag kopieren), und nach dem Speichern des Beitrags die Bilder über den Button "Bilder zu jpg konvertieren" am unteren Rand des Postings von png zu jpg umnwandeln.

    Dies gilt für alle neu hochgeladenen Bilder. Alte, bereits vorhandene Bilder müsst ihr nicht ersetzen, ihr müsst also nicht all eure alten Threads überarbeiten.
    Aber ihr dürft natürlich, wenn ihr mögt. :)

    Hier noch eine kurze Erläuterung, warum uns das so wichtig ist:

    Um Bilder zu speichern, müssen Server betrieben werden, die massig Energie verbrauchen. Je mehr Daten, um so mehr Server, logischerweise. Und dazu kommt dann noch der Traffic.
    Deshalb hier mal ein Vergleich von ein und demselben Bild in unterschiedlichen Formaten.

    Das erste ist ein png, das zweite ein jpg auf höchster Qualität, das letzte ein jpg auf mittlerer Qualität.
    Wie ihr sehen könnt, gibt es keinen nennenswerten Qualitätsunterschied bei der Präsentation im Forum. (Alle Headerbilder sind jpgs in mittlerer Qualität.)

    Und jetzt dazu die Dateigrößen:


    png - 2652 KB



    jpg, hohe Qualität - 1250 KB



    jpg, mittlere Qualität - 150 KB

    Nein, das ist kein Tippfehler. Das png ist 17 mal so gross wie das jpg in mittlerer Qualität.

    Deshalb unsere Bitte: unterstützt uns dabei, möglichst viel Energie einzusparen!
    Bitte, verwendet nur dann pngs, wenn es zwingend erforderlich ist - wenn also Transparenz benötigt wird.

    Vielen Dank!

    Wenn ihr diese Info gelesen habt, könnt ihr sie mit dem kleinen "X" oben rechts ausblenden.



SimPE - Links, Tutorials und Fragen

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Keine Ursache. :D

Es ging ungefähr so, wie ich gedacht hatte, allerdings konnte ich nicht die Originalplatte nehmen, weil die eine andere Form hatte, ich hab nur die oberen Faces ausgetauscht und an dem Counter selbst musste ich auch noch was ändern.

Hm, nee, für Laien ist das nicht relativ einfach erklärt, weil Counter schon ziemlich komplex sind und man das Objekt auch nicht als .obj importieren kann wegen der Joint-Zuordnung.

 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Mag mir mal jemand helfen, ich steh total auf dem Schlauch. Ist jetzt nur so halb ein SimPe-Problem. Eigentlich ist es ein Problem, für das SimPe nix kann, da sich das Problem aber im SimPe abspielt, dachte ich halt, dass dieser Thread dafür missbraucht werden kann.

Öhm ja.

Es geht um Buggyboozs Nooks Folly Garden Set (was ein Name). Findet man übrigens hier: http://buggybooz.blogspot.de/2012/07/nook-folly-garden.html

Das Set ist auf ein anderes Set geslaved was die Backsteintextur angeht.

In dem Folly Garden Set sind nun auch mehrere solche runden Pflanzkästen (Kästen klingt so falsch bei runden Sachen. Aber ich hoffe ihr wisst was ich meine). Diese Kästen haben zum einen eben die Backsteintextur und zum anderen eine "Füllung" innen: Gras, eine helle Fläche die Glas oder so sein könnte, Wasser und gar nix.

Jetzt hätte ich aber gerne diese Texturen, da ich die zum Rumbasteln grad bräuchte. Ich bin aber zu blöd die zu finden.

Das Gras finde ich bei "BB_Nook_FollyGarden_LargeRoundBorder.package". Aber wo ist der Rest? Und falls ich jetzt weitere Füllungen von diesen Kästen basteln will, welchen Mesh muss ich dann als Basis für die Recols benutzen?

Ich hab gefühlt jedes Package jetzt schon 10 mal aufgemacht. Aber ich blicks einfach nicht.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Isch guck ma rein. :D

EDIT: mit BB_Nook_FollyGarden_LargeRoundBorder.package lagst Du schon richtig. Im package selbst enthalten ist die Textur für das Gras, die Du ja auch schon gefunden hast, eine unsichtbare, und die anderen zwei Wasser-Recols sind auch enthalten (kannst Du erkennen, weil es vier MMATs gibt), die sind aber auf Original-Texturen verlinkt.
Die Texturen heissen hottub-waterstill (scheint aus Gute Reise zu sein, weil im TXMT-Name ein "bv" einthalten ist) und hottub-water (aus VJZ).
Wenn Du im Finder nach diesen Namen suchst, müsstest Du die Texturen finden, sofern Du im File Table GR und VJZ freigegeben hast.

Wenn Du ein Recol erstellen willst, nimmst Du BB_Nook_FollyGarden_LargeRoundBorder.package als Ausgangsbasis. Du bekommst dann bei der Subset Selection unter "plane" vier Texturen angezeigt, am besten klickst Du dann auf das Gras, dann hast Du alles im package, was Du brauchst.

 
  • Danke
Reaktionen: Ricki

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Hast du irgendwie so einen Alarm am Handy, der immer bimmelt, wenn jemand in den SimPe-Thread schreibt? :D

Danke dir. Vielleicht (hoffentlich!) hast du weniger Bretter vorm Kopf als ich.
 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Oh man, das hat sich bei mir wohl überschnitten.

Dann such ich mal die Texturen raus. Gerade bin ich im Spiel, da geht da ja schlecht mit SimPe.

Auf die Idee, dass die Texturen aus dem Spiel selbst sind, wäre ich nicht gekommen.

Danke dir :)


Edit: Wenn das Originaltexturen sind, dann könnte ich doch ggf. wenn ich nicht einen riesigen Schwurbel in den Gedanken hab, auch einfach dadrauf verlinken, wenn ich einem anderen Objekt diese Textur zuweisen möchte, oder? Konkreter: Ich möchte diese Wassertexturen beide auch für dieses "Groundteil" aus dem genannten Set. Weiß noch nicht ob diese Idee jetzt so sinnvoll ist, aber wie man Texturen "verlinkt" wollte ich schon immer gerne wissen. Eignet sich dieses Vorhaben jetzt zum Lernen oder ist das, aus welchen Gründen auch immer (z.B. weil es auf ein Originalobjekt verlinkt?) schwierig?
 
Zuletzt bearbeitet:
  • Danke
Reaktionen: julsfels

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Nö, ist nicht schwierig. Du musst nur in der TXMT unter stdMatBaseTextureName den Namen der Originaltextur eintragen, also z.B. hottub-water. Und zwar genau so, ohne das ##0x1C050000! davor, das kennzeichnet nämlich, dass es sich um eine CC-Textur handelt.
Und unter File List den Texturnamen dann auch nochmal eintragen, wie gehabt.

Das einzige, was Du bedenken musst, ist dass die UV-Map passen muss.

 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Na das klingt ja easy. Also ich erzeuge ganz normal ein Recolor und ändere dann einfach nur diese zwei Einträge ab und lösche die Texturen raus?

Das mit der UV-Map müsste ich prüfen, sollte aber hinhauen. Das jetzige Objekt ist ja groß und rund. Das neue ist etwas kleiner und quadratisch. Das Originalobjekt wiederum ist Quadratisch. Vermutlich, aber das muss ich erst nachschauen, ist das ganze einfach eine plane Textur und sämtliche Effekte werden über überlagerte Texturen gelöst.

Werde ich nach der Arbeit gleich mal testen.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Ja, das sollte eigentlich so einfach gehen.

Was mir aber noch einfällt: die Hottub-Wasser-Texturen sind eigentlich animierte Texturen. Da muss man in der TXMT noch ein paar Einträge ändern. Am besten wäre es, wenn Du einen Whirlpool klonst (klonen, weil das Wasser nicht recoloriebar ist) und die entsprechende TXMTs extrahierst und sie in Dein Recol reinholst.

Ich weiss nicht, ob das Wasser bei den Folly-Dingern auch animiert ist, falls ja, könntest Du der Einfachheit halber auch eins der Wasser-Recols im o.g. package anklicken und Dein Recol daraus erzeugen lassen.

In beiden Fällen müsstest Du dann auch den Textur-Eintrag nicht ändern, aber den Namen der TXMT anpassen, falls Du einen Whirlpool geklont hast und die TXMT reinholst.
Also den ursprünglichen Namen der TXMT kopieren, die alte TXMT löschen, die extrahierte vom Whirlpool reinholen, den kopierten Namen in die Felder Filename und und Description (unter dem Reiter cMaterialDefinition) reinkopieren (bei letzterem ohne das _txmt am Ende), dann Übernehmen und (wichtig!) fix TGI.

 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Huhu :)

Ich muss gestehen, ich bin mir gerade gar nicht sicher, ob das Wasser animiert ist. Habe in letzter Zeit ausschließlich mit dem Set gebaut und nicht gespielt. Da ich das Wasser dort aber immer total genial fand bin ich mir eigentlich ziemlich sicher, dass es animiert war.

Aber ich muss gestehen, so ganz verstehe ich das Vorgehen nicht.

Mal ganz langsam, ob ich da richtig mitkomme. Die Textur bzw. Animation ist im TXMT-Eintrag drinnen. Da das Wasser bei den Whirlpools aber nicht umfärbbar ist, bringt mir ein Recol davon nix, ich muss es klonen. Aus dem Klon dann die TXMT extrahieren und die dann irgendwie (tjoa?) in mein Recol reinholen. Das Recol wiederum lasse ich ganz normal aus dem Planter aus dem Folly-Dings erzeugen. Soweit richtig? Aber das wäre dann kein richtiger Slave auf die Originalwasserteile. Muss man das so machen, weil das durch die Animation etwas besonderes ist?

Oder slaved das dann trotzdem, weil ich die komplette TXMT übernommen habe?

Ich teste das jetzt mal und werde berichten :)


Edit: Haha, startet gut. Ich finde nur die Whirlpools aus dem Basegame. Ich such mal verzweifelt weiter :D
Edit2: Gefunden. War ein Springbrunnen. Wieso heißt dann diese dämliche Textur irgendwas mit hottube. Argh. Hab jetzt auf jeden Fall mal alles benötigte exportiert. Das ging alles einfacher als gedacht. Von der UV-Map her sollte das auch kein Problem darstellen. Ist alles quadratisch :)
Edit3: Konnte ich jetzt alles gut nachvollziehen. War alles einfacher als gedacht. Mal das Spiel laden und schauen was passiert :)
Edit4: Schnief. Irgendwas ist schief gelaufen. Die Dinger sind im Spiel, aber da scheint schonmal was mit der Transparent schief geflaufen zu sein. Das aus dem Brunnen ist nämlich komplett undurchsichtig. Animiert ist auch nix, obwohl das bei den Follydingern wirklich animiert ist. Muss ich die Texturen selbst rauslöschen und nur die TXMT-Dinger drinnen lassen?
Edit5: Die Idee von Edit4 funktioniert natürlich auch nicht. Jetzt bin ich irgendwie weiter gekommen. Das Zeugs ist animiert (yeah!) aber statt mit der gewünschten Textur (die auch ganz normal im Recol über BuildDXT getauscht wurde) habe ich einfach nur weiße Flächen mit Zahlen und roten Streifen. Yeah. Hilfe?
 
Zuletzt bearbeitet:

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Yeah! Also eines hab ich hinbekommen. Da war die Textur falsch verlinkt. Aber wieso es beim zweiten nicht geht, weiß ich gerade nicht. Muss ich glaube ich mal mit etwas Abstand betrachten.


Edit: Keine Ahnung was beim anderen schief lief. Hab es einfach noch mal neu erzeugt und jetzt geht es auch. Wunderbar :3
 
Zuletzt bearbeitet:

Cindy Sim

Member
Registriert
November 2009
Eine ganz andere Frage: Hatte hier noch jemand Probleme, wenn er das Objekt im simpe-Benennungsfenster (also nicht der eigentliche Dateiname, sondern das, wo [simpe]ewiglangezahl steht) mit einem ä ü oder ö benannt hat? Hatte letztes Mal einen "no pic" Error im Spiel, obwohl in simpe alles okay schien. Bin dann drauf gekommen, dass der Spielname in manchen Ressourcen mit einem ? anstatt des Buchstaben angezeigt wird, in anderen aber nicht. Könnte aber natürlich auch sein, dass es irgendeinen anderen Fehler gab, den ich nicht entdeckt hab. Auf jeden Fall hab ich das Maxisobjekt dann neu geklont und anders benannt, dann hat alles funktioniert. Noch jemand Erfahrungen dazu gemacht?
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Jupp, das ist so. Keine Umlaute, keine Sonderzeichen, keine Klammern, keine Unterstriche. :D

 
  • Danke
Reaktionen: Ricki und Cindy Sim

Barbie_

Newcomer
Registriert
März 2016
Fehler bei Erstellung von Townies

Hallo ihr Lieben,
ich habe folgendes Problem: Da ich mir endlich auch einmal ein paar Townies und NPCs erstellen wollte habe ich mit SimPE heruntergeladen.
Ich habe auch fleißig meine Sims erstellt und in die FFFE-Liste eingefügt. Nachdem ich es jedoch übernommen habe, kommt die Meldung ein Fehler beim Öffnen einer Datei wäre aufgetreten. Auch wenn ich dann das Programm schließe und wieder öffne sind meine Sims wieder aus dieser Liste verschwunden. Kann mir vllt jemand sagen woran das liegt oder wie ich es beheben kann? Danke schonmal in Vorraus. :)
Barbie_
 

Nona

Member
Registriert
Januar 2013
Ort
Südniedersachsen
Geschlecht
w

Woran könnte es liegen, dass erstellte Recols von CC-Objekten nicht auftauchen?
Wollte mir ein paar andere Farben der "Bright Genes" Floor Lamp (GoS, The Tchopomov Collection...ist eine Lampe die aussieht wie ein DNS-Strang) erstellen, aber im Spiel wird nichts angezeigt.
Gibts da deinen Trick? :D
 

Tigerkatze

Member
Registriert
Juni 2012
Ort
Düsseldorf
Geschlecht
w

Woran könnte es liegen, dass erstellte Recols von CC-Objekten nicht auftauchen?
Wollte mir ein paar andere Farben der "Bright Genes" Floor Lamp (GoS, The Tchopomov Collection...ist eine Lampe die aussieht wie ein DNS-Strang) erstellen, aber im Spiel wird nichts angezeigt.
Gibts da deinen Trick? :D

Kann man die Lampe recolorieren? Hast du CEP installiert?
Lösche mal die Object Thumbnails Dateien, werden bei Neustart des Spieles neu generiert.
 

Nona

Member
Registriert
Januar 2013
Ort
Südniedersachsen
Geschlecht
w

Wenn du meinst, dass man sie über den Object Workshop öffnen, die Textur ändern und speichern kann, dann ja! Das ging problemlos, so wie es hier im Forum beschrieben wurde. Hab ich auch schon "früher" öfter gemacht, da ging das ohne Probleme...aber meist nur Maxis Objekte^^. CEP habe ich auch.
Ist das die Datei im Thumbnaisl Ordner? Und die kann ich einfach löschen (also quasi wie die groups.cache usw)?
 

Zora Graves

Member
Registriert
November 2009
Geschlecht
nb

Die Lampe ist nicht recolourierbar. Das siehst du daran, dass du im Spiel mit dem Design-Tool nichts machen kannst, da kommt dann so ne kleine gelbe Meldung. Die Lampe muss also erst gefixt werden, ich versuch das auch grad.

Grundsätzlich kann man die Thumbnails-Datei löschen, aber das ist hier kein Lösungsansatz. Außerdem würden dann sämtliche Vorschaubilder im Spiel neu erstellt werden und das dauert ne kleine Ewigkeit.

Edit: Hat leider nicht geklappt, ich bin nach diesem Tutorial vorgegangen (wie auch schon öfter zuvor). Was mich an der Lampe eh wundert ist, dass sie nur eine Textur hat und nicht zwei wie andere Lampen (eine für den beleuchteten und eine für den unbeleuchteten Zustand). Ich vermute, dass die Objekte irgendwie merkwürdig erstellt wurden (ich hatte die früher mal im Spiel und hab die dann rausgeschmissen weil da irgendwas komisch war, aber ich kann mich an den Grund nicht mehr erinnern).
 
Zuletzt bearbeitet:

Nona

Member
Registriert
Januar 2013
Ort
Südniedersachsen
Geschlecht
w

Das mit der Textur hat mich auch schon gewundert, weswegen ich im Hinterkopf schon die Vermutung hatte dass mit dem ganzen Ding etwas nicht stimmt :D

Die Namen sind nicht doppelt, habe alles ganz brav nach Farben benannt "DNA-Lamp-Green" usw.

Danke für's versuchen!
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Die Lampe ist nicht recolourierbar. Das siehst du daran, dass du im Spiel mit dem Design-Tool nichts machen kannst, da kommt dann so ne kleine gelbe Meldung.
Ah, nicht zwangsläufig. Diese Meldung erscheint auch manchmal, wenn mit den Recolors was nicht in Ordnung ist, unabhängig davon, ob das Objekt prinzipiell recolorierbar wäre oder nicht.

Bist Du denn schon fündig geworden? Sonst gucke ich auch nochmal rein.
Nona, wie heissen Deine Recolor-Packages? Gibt es die Namen doppelt?

EDIT: ok, hast ja schon geantwortet. :D Ich guck auch mal rein. Aber jetzt muss ich erstmal frühstücken. :lol:

EDIT2: So. Das. Okay. :D Also. :lol:
Lampen haben States (an- und ausgeschaltet), und wenn die recolorierbar sein sollen, muss man da ein paar Dinge beachten und ein paar Namenskonventionen einhalten.
Folgendes habe ich geändert:

  • In der GMDC den Namen der Metall-Meshgroup entsprechend den Namenskonventionen geändert
  • In der GMND den Eintrag tsDesignModeEnabled ergänzt und beide Meshgroups (den Metallsteg und die Birnen) zum Recolorieren freigeschaltet sowie die überflüssigen GMND-Einträge rausgeworfen
  • Die fehlende TXMT für den zweiten State der Metall-Meshgroup zugefügt und den Namen der vorhandenen entsprechend den Namenskonventionen geändert
  • MMATs für die Birne zugefügt, die fehlende MMAT für den zweiten State der Metall-Meshgroup zugefügt und den Namen der vorhandenen entsprechend den Namenskonventionen geändert
  • Die Einträge in den Text Lists auf die richtigen Werte gesetzt (Material- und Meshgroupnamen)
  • In der SHPE den Meshgroupnamen und den Materialnamen für die Metall-Meshgroup geändert und die überflüssigen Werte rausgeschmissen

In der neuen TXMT für den angeschalteten Zustand der Metall-Meshgroup habe ich ein paar Änderungen vorgenommen, damit der Metallsteg etwas heller ist und reflektiert, wenn das Licht an ist.



Jeweils links im angeschalteten Zustand, rechts im ausgeschalteten. Das zweite Bild ist mein Testrecolor.



Ist dann auch getrennt recolorierbar.


Ich habe mein Testrecolor mal mit in das Zip reingepackt, damit Du reinschauen kannst. Für das Recolor der Metall-Meshgroup brauchst Du nur im Recolorpackage die Textur austauschen, der Rest passiert automatisch.
Die Birne hat keine Textur, da musst Du in der TXMT die Farbwerte eintragen. Ich habe in meinem Testrecolor für den angeschalteten Zustand (die TXMT mit bulb_lit im Namen) ein helleres Orange genommen, für den ausgeschalteten Zustand (die TXMT mit bulb_unlit im Namen) ein graueres Orange.
Den eigentlichen Farbwert trägst Du dann jeweils im Feld stdMatDiffCoef ein, wie das geht (wie Du die Farbe umrechnest) ist hier beschrieben, unten bei "Farbwerte".
Für den ausgeschalteten Zustand brauchst Du nur den Wert bei stdMatDiffCoef ändern, beim angeschalteten Zustand habe ich ihn auch noch in stdMatEmissiveCoef eingetragen - man kann die Lichtfarbe bei Lampen in Recolors leider nicht ändern, aber dieser Wert passt zumindest den "Glow" der Birne etwas farblich an.

Ach, und nochwas: falls Du vorziehen würdest, dass die Birnen durchsichtig sind, müsstest Du einfach nur in den beiden TXTMTs für die Birne (die mit bulb im Namen) den Wert von stdMatAlphaBlendMode auf blend umsetzen. Ich hab das jetzt nicht geändert, weil ich nicht wusste, inwieweit Dir das Recht ist, deshalb hab ich es nur so weit vorbereitet, dass man nur diesen Wert umsetzen muss.

Hier ist der gefixte Mesh und das Testrecolor: LaM_DNAFloorLamp

Falls was nicht klappt oder Du Fragen hast, meld Dich einfach. ;)

 
  • Danke
Reaktionen: Nona und Zora Graves

Amy.Chagall

Member
Registriert
Januar 2012
Ort
Schönschüchtingen
Geschlecht
w

Hallo! Ich hoffe, hier kann mir jemand helfen bitte?

Ich dachte erst, es liegt an einem Objekt, aber dann stellte ich fest, dass meine Translation im CRES alle anderen Objecte genauso darstellt. Mir fehlt das Z in der Translation, um Slots zu bearbeiten. Ich habe schon das Internet nach solch einem Problem druchsucht, aber leider nichts gefunden. Muss ich im SimPe iwas einstellen? Kann mich nicht mehr erinnern.

[url=http://www.fotos-hochladen.net] [/URL]
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Ich glaube, das fehlt nicht, sondern da ist was mit dem Bild verrutscht - die Begrenzungslinien um die Kästchen rum, da wo "Translation" steht, sind ja einfach abgeschnitten. Hast Du Vielleicht am rechten Rand eine Scrollbar?

Oder geh doch mal auf Extras/Einstellungen/Einstellungen, da gibt es einen Button "Layout zurücksetzen". Vielleicht hilft das ja.

 
  • Danke
Reaktionen: Amy.Chagall

Amy.Chagall

Member
Registriert
Januar 2012
Ort
Schönschüchtingen
Geschlecht
w

Hallo Julsfels,
ja - das Layout zurücksetzen hat geholfen, das war tatsächlich verrutscht, aber mit der Scrollbar am rechten Rand war es nicht zu erreichen. Leider erst mit dem "Layout zurücksetzen". Leider ist jetzt mein Objectworkshop auch nach unten gerutscht, eigentlich habe ich ihn lieber rechts. Aber na ja, so sehe ich endlich die ganze Translations Optionen.

Vielen Dank liebe Julsilein, hast mir sehr geholfen :-)
 

Tanuri

Newcomer
Registriert
Februar 2015
Ich brauche mal ein bißchen Hilfe

Hallo,

ich arbeite schon lange mit SimPe, habe aber noch längst nichts alles verstanden.

Frage 1: Wofür sind Material Overides (MMAT) da? In manchen packages sind MMAT's drin und in anderen nicht. Warum? Subfrage 1: Kann man MMat's erstellen, wenn in dem packages noch keine sind? Wenn ja, wie?

Frage 2: Was sind tsDesignModeSlaveSubsets? Und spielen sie eine Rolle, wenn man Texturen ändern will?

Frage 3: muss man im Shape immer das ##0x1C5000 vor den Namen der Textur schreiben? meistens steht es ja bei der txtr und txtm nicht vor dem Namen.

Bis bald, Tanuri
 

Cindy Sim

Member
Registriert
November 2009
Julsfels kann das sicher viel professioneller erklären, aber ich versuch's mal :)

1. Die MMATs verknüpfen praktisch Textur und Meshsubset, bzw. Material Definitions und Meshsubset. Plus noch ein paar andere Sachen, die ich nicht so genau weiß. Schatten haben z.B. oft keine MMAT. So ganz blick ich da auf jeden Fall auch nicht durch.
Auf jeden Fall: Wenn du ein neues Subset mit einer Textur hinzufügen willst, das vorher nicht in der package war, musst du dem eine MMAT geben, zum Beispiel, indem du eine andere MMAT klonst und ihr einen neuen Namen gibst. Wenn deine Datei keine MMAT hatte, kannst du sie aus einer anderen Datei extrahieren und ihren Namen in die neue Datei anpassen. Außerdem musst du in der MMAT selbst ein paar Werte ändern. Die Frage ist, wieso willst du das überhaupt machen, außer, wenn du ein Subset hinzufügst? Wenn in der Datei keines ist, solltest du eigentlich auch keines brauchen.

2. Da bin ich mir auch nicht ganz sicher, aber das hängt meistens damit zusammen, wie das Objekt im Nachbarschaftsmodus angezeigt wird. Kann aber auch sein, dass es teilweise mitverantwortlich ist, wenn Maxisobjekte ihre Textur von einem anderen Maxisobjekt beziehen. Normalerweise kannst du die einfach ignorieren.

3. Ja, muss man, es sei denn, dein Objekt bezieht die Textur von einem Maxisobjekt (also nicht von einem geklonten, sondern dem Original), du hast es also auf dieses geslaved. Wenn du das nicht gemacht hast, musst du es davor schreiben.

Ich glaub, ich könnte dir etwas mehr helfen, wenn du schreibst, was du konkret vorhast.
 

Tanuri

Newcomer
Registriert
Februar 2015
Hallo Cindy Sim,

vielen danke für die schnelle Antwort.

Was ich konkret machen will, ist, eine Lampe und einen Stuhl zum "Sklaven":-) der Bettwäsche zu machen.

bei der Lampe ist es mir schonmal gelungen, aber ich weiß leider nicht mehr, wie ich es damals gemacht habe. In der jetzigen Version übernimmt der Lampenschirm brav die Bettwäsche-Textur, aber der Lampenfuss blinkt nur blau, obwohl er in Simpe mit Textur angezeigt wird.

Der Stuhl zeigt die textur korrekt an, aber bei dem Sitzkissen wird nur die Bedding Blue angezeigt, die anderen fehlen.

Ich musste für beiden Objekte neue Meshgruppen einfügen, dafür habe ich die vorhandene Objekt-Datei einfach geteilt, dann habe ich so weitergemacht, wie es in der Anleitung steht, die ich bei blackypanther.de gefunden habe. Aber irgenwie ist da der Wurm drin.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Frage 1: Wofür sind Material Overides (MMAT) da? In manchen packages sind MMAT's drin und in anderen nicht. Warum? Subfrage 1: Kann man MMat's erstellen, wenn in dem packages noch keine sind? Wenn ja, wie?
Material Overrides sorgen, wie der Name sagt, für das Überlagern eines Materials im Spiel. Sprich, man braucht sie für Recolors.
Zum Zufügen einer MMAT, wenn keine vorhanden ist, importierst Du Dir, wie Cindy bereits sagte, eine aus einem anderen package und verfährst dann wie in dem Tutorial Zufügen einer Meshgroup unter Punkt drei beschrieben.

Frage 2: Was sind tsDesignModeSlaveSubsets? Und spielen sie eine Rolle, wenn man Texturen ändern will?
SlaveSubsets bündeln Meshgroups zu einer logischen Einheit. Das braucht man, wenn Meshgroups unterschiedliche States haben, wie bei der von Cindy erwähnten LOD-Verwaltung, oder auch bei Lampen, die einen ein- und ausgeschaltet-Zustand haben.

Frage 3: muss man im Shape immer das ##0x1C5000 vor den Namen der Textur schreiben?
Ja, muss man.


Ich musste für beiden Objekte neue Meshgruppen einfügen, dafür habe ich die vorhandene Objekt-Datei einfach geteilt, dann habe ich so weitergemacht, wie es in der Anleitung steht, die ich bei blackypanther.de gefunden habe. Aber irgenwie ist da der Wurm drin.
Du kannst ja nochmal mein oben verlinktes Tutorial zum Zufügen einer neuen Meshgroup durchgehen, vielleicht fällt Dir da was auf.

 
  • Danke
Reaktionen: Cindy Sim

Tanuri

Newcomer
Registriert
Februar 2015
hallo julsfels,

ich habe es noch einmal nach deinem Tutorial versucht, mir sind in der Tat Unterschiede aufgefallen.

Bei dem Stuhl hat es prima geklappt, bei der Lampe leider nicht(da hat vsich das Problem gelöst, als ich ein Recolor auf den Lampenfuss gelegt habe- allerdings wird es nicht angezeigt).

Bist du dir eigentlich sicher, was die Eindeutigkeit der MMAt's angeht? Hast du eine Liste mit bereits vergebenen Instanzen? ich beforzuge eigentlich die neue GUID über die Objekt-Data zu vergeben und die MMAt's da einzubinden.
 

julsfels

SimForum Team
Registriert
Juli 2006
Ort
Marburg
Geschlecht
w

Es gibt bei MMATs keine Liste mit vergebenen Instanzen. Die Instanzen haben nichts mit GUIDs zu tun, die werden sozusagen intern "errechnet", i.d.R. wird der Name der Resource dazu herangezogen, das kann man schön sehen, wenn man den Namen ändert und FIX TGI macht.
GUIDs haben nichts in Instanznummern zu suchen.

Die GUID, die man in den MMATs im Feld GUID einträgt, identifiziert auch nicht die MMAT, sie muss zwingend die GUID aus der OBJD des Mesh-Objekts sein. Sie bindet, zusammen mit dem CRES-Namen, das Recolor an den Mesh.

 

SimMichi

Newcomer
Registriert
November 2010
Ort
NewVegas
Geschlecht
w

Hallo!
Ich möchte gerne Teile aus Villen und Gartenaccessoir umfärben mit Simpe.Da ich die Version Ultimate Collection habe,sind die File Tabel nicht richtig geladen,deshalb habe ich mir diesen fix runtergeladen,aber ich kann machen was ich will,der Workshop zeigt mir nur das Hauptspiel und Weihnachtssachen an.
Habe die vorletzte Version von Simpe,weil ich sonst nicht die Dateien mit Doppelklick öffnen kann.
Vielen Dank im voraus!


Jetz hat es geklappt-hab jedes Addon nochmal in den Verzeichnissen zugewiese-in den File Table alles deaktiviert,außer CEP und Base und oben rechts auf neu laden-Simpe geschlossen-wieder Häckchen an bei den Addons-oben wieder rechts den Button neu laden gedrückt-workshop geladen und endlich waren Sachen da--hab aber nicht den File Test ausgeführt!
 
Zuletzt bearbeitet:

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Ich versuche gerade einen Maxis-Mesh zu recolorieren: Collage in schwarzweiß. Das ist dieses Wandbild aus vielen kleinen Bildern.

Aber es erzeugt mir immer nur ein leeres package. Es sagt "Object was created" und fertig. Habe es jetzt testweise nochmal mit ein paar Maxis-Bildern probiert. Bei ein paar war der selbe Fehler, bei anderen nicht.

Gerade diese Collage habe ich aber schon mehrfach umgefärbt. SimPe wurde mehrfach neu gestartet. Jemand eine Idee, wo der Fehler liegen könnte?
 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

War in einem Unterordner, hab es jetzt auf oberste Ebene verschoben (also im DL-Ordner natürlich), trotzdem das selbe Spiel. Hab es auch in meinem Hauptspielstand kurz probiert, gleiches Ergebnis.


Edit: Neu herunterladen des CEPs hat auch keine Auswirkung :/
 
Zuletzt bearbeitet:

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Perfekt, das war der Fehler.

Im neuen Spielstand war das wohl nie installiert und im alten hab ich das ganze gerade feinsäuberlich mit der neuinstallation des CEPs überschrieben :D

Ich war vorhin sogar so verzweifelt, dass ich es schon über den "Wizards of SimPE" testen wollte (ging übrigens auch nicht).



Edit: Falls andere auch das Problem haben: https://hafiseazale.dreamwidth.org/16076.html Das ist der richtige Link. Beim anderen geht der Download nicht mehr.
 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

*Doppelpost, aber jetzt hab ich ein neues Problem mit dem Bild*

Ich schon wieder. :D

Durch den Fix, hab ich jetzt wunderbar zwei Subsets, aber ich bin zu blöd die richtig zu benutzen. Jetzt hab ich wunderbar den Rahmen umgefärbt, klappt auch toll, aber eigentlich wollte ich eher die Familienbilder einfügen. Es kommt aber keine Auswahl bezüglich der Subsets am Anfang bei dem Bild. Das ist doch wie verhext.
 

OmiOphelie

Newcomer
Registriert
März 2005
Hallo ich habe da eine hoffe ich einfache Frage, aber ich bin zu doof danach zu suchen, weil ich nicht genau weiss, wie die Keywords in SimPE sind, nach denen ich suchen muss. Ich habe das Problem, dass ich in meinen Downloads Gardinen habe, die Clipping Fehler mit Fensterrahmen und Gegenständen wie Betten oder Sofas haben. D.h. der Fensterrahmen schaut durch die Gardine durch und die Gardine hängt über dem Body vom Bett bzw. Sofa. Wie kriege ich da eine passende Reihenfolge in den Ebenen hin? (Selbiges Ebenenproblem habe ich bei einigen Klamotten auch). Vielleicht könnt ihr mich ja ein wenig erleuchten, denn ich bin mit meiner Wortpalette zur Suche am Ende meiner Weisheit angelangt :)
 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Ich bin mir nicht sicher, ob ich es richtig verstehe. Die Textur vom Vorhang wird also vor dem Sofa angezeigt, obwohl das Sofa vor dem Vorhang platziert ist? Sowas hatte ich ständig mit meiner alten Grafikkarte am alten Rechner. Der kam mit mehreren transparenten Sachen (also Fenster, Vorhang usw.) nicht klar und hat dann komische Grafikfehler angezeigt.

Oder ist der Vorhang einfach zu voluminös und guckt deshalb raus? Da kannst du dann einfach das Objekt frei vom Gitter platzieren.


Hast du mal ein Beispielbild oder einfach mal einen Link zu betroffenen Vorhängen?

---

Mein Problem oben konnte übrigens so halbwegs gelöst werden. Mehreres Löschen der SimPe-Cache-Dateien sowie ein erneutes verknüpfen der CEP-Ordner hat geholfen. Es zeigt mir jetzt ein Subset an (obwohl es ja zwei sind) und das Subset heißt auch Frame, scheint aber für das Bild selbst zu sein. Da ich aktuell nur das Bild brauche und nicht den Rahmen, geht das erstmal. Notfalls kann ich auch meinen Rahmen-Versuch umfärben. Auch wenn das glaube ich "nicht so gesund ist", sollte zur Not auch ein Recol vom Recol gehen.
 

OmiOphelie

Newcomer
Registriert
März 2005
Hallo danke für deine Antwort :) Hier ist ein Screen


Und ich habe noch ein neues Problem :) Habe meine Downloads aufgeräumt und dabei festgestellt, dass bei einigen scheinbar die Texturen nicht richtig belegt werden. D.h. das Item ist zwar korrekt, aber mitten drin gibt es Meshteile, die nicht mit einer Texture belegt sind. Kann man das irgendwie fixen?

Screen:

(Die Schüssel ist leuchtend blau, der Rest passt)
 

Anhänge

  • snapshot_00000011_249cf3a8.jpg
    snapshot_00000011_249cf3a8.jpg
    12,3 KB · Hits: 192
  • snapshot_00000011_c49cf3ce.jpg
    snapshot_00000011_c49cf3ce.jpg
    8,5 KB · Hits: 189

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Beim ersten sind die Objekte einfach so groß, dass sie in andere Objekte "reinlaufen". Das kann man in SimPe selbst nicht ändern. Hier müsste man den Mesh verkleinern. Man kann aber auch einfach die Objekte frei vom Gitternetz platzieren (boolprop snapobjectstogrid false).

Wenn ein Objekt blau blinkt, dann heißt das in der Tat, dass da eine Textur fehlt. Ist das ganze möglicherweise Teil eines Master/Slave-Sets? Dann fehlt möglicherweise die Datei, die die Textur für den Topf (? sieht man auf dem Bild schlecht) enthält.
 

OmiOphelie

Newcomer
Registriert
März 2005
Beim ersten sind die Objekte einfach so groß, dass sie in andere Objekte "reinlaufen". Das kann man in SimPe selbst nicht ändern. Hier müsste man den Mesh verkleinern. Man kann aber auch einfach die Objekte frei vom Gitternetz platzieren (boolprop snapobjectstogrid false).

Ah, ok, danke. Würde das dann bedeuten, dass bspw das Bett dann 8 statt 6 Slots "verbraucht"? :idee:

Wenn ein Objekt blau blinkt, dann heißt das in der Tat, dass da eine Textur fehlt. Ist das ganze möglicherweise Teil eines Master/Slave-Sets? Dann fehlt möglicherweise die Datei, die die Textur für den Topf (? sieht man auf dem Bild schlecht) enthält.

Naja, blinken tut es ja nicht wirklich, es ist einfach blau. Master-/Slave müsste ich schauen. Möglich wäre es, weil es davon auch noch andere Räume gibt. Aber bei den anderen Items, bei denen Teile blau sind, ist das nicht der Fall. Ich habe auch teilweise das Phänomen, dass im Katalog Teile blau sind, aber im Spiel korrekt angezeigt werden, das hatte ich auf das Master-/Slave-Problem geschoben. (Oh man, ich hab das Gefühl, dass es mir das Hirn verknotet, weil ich mich solange nicht damit beschäftigt hab... und in Skyrim bastelt man sich sein Haus so hin, wie man es will %))
 
Registriert
September 2015
Ah, ok, danke. Würde das dann bedeuten, dass bspw das Bett dann 8 statt 6 Slots "verbraucht"? :idee:
Jein. Das betrifft nur andere Objekte, die selbst einen kompletten Slot belegen. Die meisten lassen sich aber auch auf teilbelegte Slots setzen.

Probleme kann es dabei aber mit Objekten geben, mit denen Sims interagieren. In deinem Fall würde ich nicht das Bett verschieben, sondern den Vorhang. Bei Betten weiß ich es nicht, aber manche Objekte können nicht mehr benutzt werden, wenn sie nicht im Raster plaziert sind.
 

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Alle Objekte, die mit anderen Objekten interagieren (z.B. Stuhl mit Tisch) können nicht einfach so frei platziert werden, da dann die Funktionalität verloren geht. Das kann man aber mit dem Cheat, mit dem man die Kacheln vierteln kann, lösen. Dazu braucht man aber Villen und Garten.

Ansonsten gibt es manchmal Routingprobleme d.h. den Sims steht etwas im Wege, wenn man Sachen frei platziert. In Häusern, die ich wirklich spiele, stelle ich dann oft Objekte, die im Weg stehen könnten (z.B. ein Nachttisch) auf spezielle sogenannte OMSP, die es einem ermöglichen, dass die Sims entweder durch das Objekt laufen (das macht bei Bodendeko Sinn) oder direkt um das Objekt herum. Das geht aber nur mit Objekten, die nur ein Bodenteil groß sind.


Wenn im Katalog etwas blau ist, im Spiel aber nicht, dann wurde die Textur inzwischen hinzugefügt. Man kann Katalogbilder auch aktualisieren lassen. Ich meine das geht, wenn du mit gedrückter STRG-Taste und der rechten Maustaste auf das Katalogbild klickst. Aber vielleicht ist es auch die normale linke Taste? Ich bin mir da gerade unsicher.

Wegen der Objekte, die jetzt immer noch blau sind, hast du da ggf. mal einen Link zu? Dann kann man sich das mal anschauen. Möglicherweise fehlt dir auch ein Addon? Aber ich weiß nicht, ob es dann auch blau blinkt, wenn es sich Texturen von einem Spielobjekt aus einem fehlenden Addon zieht.
 

OmiOphelie

Newcomer
Registriert
März 2005
Heieieieiei... danke für die Erklärungen :) Das Set aus dem Beispiel ist "Dincer DH Lightwood Kitchen" - das ist mir aber auch noch bei Tellern von "Colonial Upper Cabinet with platerack by Mutske" aufgefallen. AddOns habe ich alle, sowie auch alle AccessoriesPacks - hat eine halbe Ewigkeit gedauert das alles zu installieren - sind auch alles Originale, also keine gebrauchten oder sonstwie beschafften Data. Die Downloads waren alle geprüft mit diesem Tool und damals lief auch alles. Sind auch nur welche von bekannteren Fansites wie TSR, MTS und wie sie alle heissen, also keine, bei denen man um die Qualität fürchten müsste (die Payloads sind auch alle brav bezahlt).

Eine Frage habe ich noch: mit welchem Cheat kann man "Kacheln vierteln"? Was muss ich mir denn darunter vorstellen?

Ganz lieben Dank für die ausdauernde Hilfe! :up:
 
Zuletzt bearbeitet:

Ricki

Member
Registriert
Dezember 2005
Alter
30
Ort
bei Karlsruhe
Geschlecht
w

Nur ganz kurz, da ich gerade auf dem Sprung bin:

Bei der Küche sind die Teller blau. Das gehört so. Sieht man auch am Beispielbild. Bei den Hängeschränken weiß ich es aber gerade nicht.

Cheat noch kurz: set QuarterTilePlacement on
Aktivieren muss man den dann auch noch. Ich meine mit der Taste F.
 

Zur Zeit aktive Besucher

Oben Unten